Hello everyone,
We are in the process of carrying out the update step by step. First we update all services with the outdated workflows and then we switch to the new architecture with the extension. Unfortunately, we have a problem with the deprecated workflows and when we try to log in via the API (engine-rest) or via the cockpit, we get a server error (500) with the following trace:
Servlet.init() for servlet [Admin Api] threw exception
org.glassfish.hk2.api.MultiException: A MultiException has 2 exceptions. They are:
1. java.lang.IllegalStateException: Could not find an implementation of ClassAnalyzer with name default
2. java.lang.IllegalArgumentException: Errors were discovered while reifying SystemDescriptor(
implementation=org.jvnet.hk2.internal.DynamicConfigurationServiceImpl
contracts={org.glassfish.hk2.api.DynamicConfigurationService}
scope=jakarta.inject.Singleton
qualifiers={}
descriptorType=CLASS
descriptorVisibility=LOCAL
metadata=
rank=0
loader=null
proxiable=null
proxyForSameScope=null
analysisName=null
id=2
locatorId=0
identityHashCode=218355242
reified=false)
at org.jvnet.hk2.internal.Collector.throwIfErrors(Collector.java:65) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.Utilities.handleErrors(Utilities.java:363) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.igdCacheCompute(ServiceLocatorImpl.java:1205) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl$8.compute(ServiceLocatorImpl.java:1186) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl$8.compute(ServiceLocatorImpl.java:1183) ~[hk2-locator-3.0.6.jar:na]
at org.glassfish.hk2.utilities.cache.internal.WeakCARCacheImpl.compute(WeakCARCacheImpl.java:105) ~[hk2-utils-2.6.1.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.internalGetDescriptor(ServiceLocatorImpl.java:1266) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.internalGetService(ServiceLocatorImpl.java:765) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.internalGetService(ServiceLocatorImpl.java:732) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:702) ~[hk2-locator-3.0.6.jar:na]
at org.glassfish.hk2.utilities.ServiceLocatorUtilities.addClasses(ServiceLocatorUtilities.java:410) ~[hk2-api-2.6.1.jar:na]
at org.glassfish.hk2.utilities.ServiceLocatorUtilities.enablePerThreadScope(ServiceLocatorUtilities.java:83) ~[hk2-api-2.6.1.jar:na]
at org.glassfish.jersey.inject.hk2.AbstractHk2InjectionManager.createLocator(AbstractHk2InjectionManager.java:92) ~[jersey-hk2-3.1.6.jar:na]
at org.glassfish.jersey.inject.hk2.AbstractHk2InjectionManager.<init>(AbstractHk2InjectionManager.java:62) ~[jersey-hk2-3.1.6.jar:na]
at org.glassfish.jersey.inject.hk2.ImmediateHk2InjectionManager.<init>(ImmediateHk2InjectionManager.java:38) ~[jersey-hk2-3.1.6.jar:na]
at org.glassfish.jersey.inject.hk2.Hk2InjectionManagerFactory$Hk2InjectionManagerStrategy$1.createInjectionManager(Hk2InjectionManagerFactory.java:55) ~[jersey-hk2-3.1.6.jar:na]
at org.glassfish.jersey.inject.hk2.Hk2InjectionManagerFactory.create(Hk2InjectionManagerFactory.java:73) ~[jersey-hk2-3.1.6.jar:na]
at org.glassfish.jersey.internal.inject.Injections.createInjectionManager(Injections.java:81) ~[jersey-common-3.1.6.jar:na]
at org.glassfish.jersey.server.ApplicationHandler.<init>(ApplicationHandler.java:274) ~[jersey-server-3.1.6.jar:na]
at org.glassfish.jersey.servlet.WebComponent.<init>(WebComponent.java:311) ~[jersey-container-servlet-core-3.1.6.jar:na]
at org.glassfish.jersey.servlet.ServletContainer.init(ServletContainer.java:154) ~[jersey-container-servlet-core-3.1.6.jar:na]
at org.glassfish.jersey.servlet.ServletContainer.init(ServletContainer.java:339) ~[jersey-container-servlet-core-3.1.6.jar:na]
at jakarta.servlet.GenericServlet.init(GenericServlet.java:143) ~[tomcat-embed-core-10.1.24.jar:6.0]
at jakarta.servlet.http.HttpServlet.init(HttpServlet.java:121) ~[tomcat-embed-core-10.1.24.jar:6.0]
at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:837) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:794) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:575) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:115) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:90) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:482) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:115) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:93) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:74) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:344) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:389) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:63) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:896) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1741) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:52) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.tomcat.util.threads.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1190) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.tomcat.util.threads.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:659) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:63) ~[tomcat-embed-core-10.1.24.jar:10.1.24]
at java.base/java.lang.Thread.run(Thread.java:840) ~[na:na]
Caused by: java.lang.IllegalStateException: Could not find an implementation of ClassAnalyzer with name default
at org.jvnet.hk2.internal.ServiceLocatorImpl.getAnalyzer(ServiceLocatorImpl.java:2468) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.Utilities.getClassAnalyzer(Utilities.java:143) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ClazzCreator.initialize(ClazzCreator.java:95) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ClazzCreator.initialize(ClazzCreator.java:165) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.SystemDescriptor.internalReify(SystemDescriptor.java:719) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.SystemDescriptor.reify(SystemDescriptor.java:673) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.reifyDescriptor(ServiceLocatorImpl.java:438) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.narrow(ServiceLocatorImpl.java:2316) ~[hk2-locator-3.0.6.jar:na]
at org.jvnet.hk2.internal.ServiceLocatorImpl.igdCacheCompute(ServiceLocatorImpl.java:1192) ~[hk2-locator-3.0.6.jar:na]
... 40 common frames omitted
Have we missed something in your documentation or is something missing?
I have created a demo project but unfortunately I can’t attach it