Hi all,
Regarding the topic that I raised The loadAttachmentUrl operation returns a 200 OK response code and an error response body - Data Services - mgm A12 Discourse (geta12.com).
Based on @petr-high-peak’s comment, the response is expected from DS. Therefore, if DS returns such a response, the attachment handler should manage the error. Otherwise, nothing happens when an error occurs.
Is my understanding correct?
Hi @quynh-still-birch,
I checked our code and the reason is that the server error is caught and logged - but we should actually forward it to the attachment handler’s error handler. Which in turn would display the error at the attachment control.
Could you please create a bug ticket for us?
Thank you,
Baschir
Thanks for your reply, @baschir-loud-bluff. I have created the ticket A12-15417.
Hi everyone,
A12-15417 has been implemented and will be released in 2023.06-ext5.
Best,
Denise