ModelGraphGenerator error after A12-Upgrade to 2025.06

We are calling ModelGraphGenerator from Gradle Build Script.

The resulting call looks like this:

Starting process ‘command ‘C:\Program Files\Zulu\zulu-21\bin\java.exe’’. Working directory: C:-Projects-\kdialog-sii-au\kdialog-sii-au-models Command: C:\Program Files\Zulu\zulu-21\bin\java.exe -Dfile.encoding=UTF-8 -Duser.country=DE -Duser.language=de -Duser.variant -cp C:\gradle.tmp\gradle-javaexec-classpath17948417590495009953.jar com.mgmtp.a12.dataservices.tooling.modelgraph.ModelGraphGenerator –output=C:-Projects-\kdialog-sii-au\kdialog-sii-au-models\build\models\modelGraph.json C:-Projects-\kdialog-sii-au\kdialog-sii-au-models\models\auftragsuebersicht-document.json,C:-Projects-\kdialog-sii-au\kdialog-sii-au-models\models\auftragsuebersicht-mini-overview.json,C:-Projects-\kdialog-sii-au\kdialog-sii-au-models\models\auftragsuebersicht-overview.json,C:-Projects-\kdialog-sii-au\kdialog-sii-au-models\models\auftragsuebersicht-sl-overview.json

This results in the following error:
2025-08-13T11:25:44.166+0200 [QUIET] [system.out] 0 [main] ERROR com.mgmtp.a12.dataservices.tooling.modelgraph.ModelGraphGenerator - Unable to start the application.
2025-08-13T11:25:44.166+0200 [QUIET] [system.out] com.mgmtp.a12.dataservices.common.exception.UnexpectedException: java.nio.file.InvalidPathException: Illegal char <:> at index 52: C:/-Projects-/kdialog-sii-au/kdialog-sii-au-models/C:/-Projects-/kdialog-sii-au/kdialog-sii-au-models/models/auftragsuebersicht-document.json
2025-08-13T11:25:44.166+0200 [QUIET] [system.out] at com.mgmtp.a12.dataservices.tooling.modelgraph.ModelGraphGenerator.getJsonResources(ModelGraphGenerator.java:126)
2025-08-13T11:25:44.166+0200 [QUIET] [system.out] at com.mgmtp.a12.dataservices.tooling.modelgraph.ModelGraphGenerator.lambda$run$1(ModelGraphGenerator.java:78)

The parameters given for the model files are geting an additional path in front (maybe working directory) which leads to an error.

I tried also with separate parameters for each file instead of comma separated concatenated string.

Am I doing something wrong? Is there a workaround?

Hi @andreas-sleek-frost,

you must now use URLs to specify models. It is documented here, hidden among the wall of other breaking changes :smiley: So it should work if you prepend file:/// to all inputs. And I didn’t know comma separated paths are possible, we always just specified the folder and it picked up all models.