Initial rpc of documents fails

Hi, after upgrading to 2024.06 the initial upload of the documents fails. The error message is “SearchServiceException: null” caused by “Connection refused: no further information”.

I changed the deprecated config from path to paths and have following configs now:
→ initialization.scripts.jsonRpc.enabled: true
→ initialization.scripts.jsonRpc.paths: path/to/files

What can I do here?

Hi,
Please try to check the profile of search engine, have you change the name of solr profiles from embedded_solr -> dataservices-embedded_solr ?
( If you using the embedded profile )

Hi, we are not using any specific profiles, at least not that I know of. It should all be the default behaviour configured through a yaml file.

So please check the configurations of search service in your yaml file.
If does not have, please config them and try to restart app to see the result.

Because your log shows SearchServiceException: Null, so I think it doesn’t have the configuration for search service or the configuration may be wrong.

@nick-linked-tensor, did it help?

Hi sorry for the late response, I had problems opening discourse. I added all properties defined in the profile “dataservices-embedded_solr” but it is still trying to connect to a external solr as it seems. what searchService config are you referring to? mgmtp.a12.dataservices.search.service=solrclient?

Turns out I used the wrong default.yaml because we have two. I also had to include compileOnly(“javax.servlet:javax.servlet-api:4.0.1”) in our build.gradle. It now works as expected. Thanks @long-narrow-bloom!