Hikari pool error log

From A12 Version 2025.06-ext4 we get permanent ERROR-logs at every start of Dataservices-Application and can’t fix it:

2026-05-12 18:35:48.636 [        ]  INFO [bv2,,] 18412 --- [  restartedMain] org.reflections.Reflections              : Reflections took 80 ms to scan 13 urls, producing 332 keys and 1299 values
2026-05-12 18:35:48.766 [        ]  INFO [bv2,,] 18412 --- [  restartedMain] org.reflections.Reflections              : Reflections took 38 ms to scan 13 urls, producing 332 keys and 1299 values
2026-05-12 18:35:48.996 [        ] ERROR [bv2,,] 18412 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-3 - dataSource or dataSourceClassName or jdbcUrl is required.
2026-05-12 18:35:48.996 [        ] ERROR [bv2,,] 18412 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-3 - dataSource or dataSourceClassName or jdbcUrl is required.
2026-05-12 18:35:49.000 [        ] ERROR [bv2,,] 18412 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-4 - dataSource or dataSourceClassName or jdbcUrl is required.
2026-05-12 18:35:49.002 [        ] ERROR [bv2,,] 18412 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-4 - dataSource or dataSourceClassName or jdbcUrl is required.
2026-05-12 18:35:49.108 [        ]  INFO [bv2,,] 18412 --- [  restartedMain] .u.c.r.c.UAARestClientPropertiesResolver : Resolve properties for: LOCAL
2026-05-12 18:35:50.329 [        ]  INFO [bv2,,] 18412 --- [  restartedMain] c.m.a.u.a.u.i.UAALocalUserManager        : Loaded [7] local users.

Here is the debug state, when error occurs:

it happens during initialisation of HikariPool-1:

Our analyzings:

HikariPool-3 and HikariPool-4 arise because the A12 monitoring component—via reflection—erroneously accesses the existing data sources (Pool-3 from Pool-1/dataservices; Pool-4 from Pool-2/contentstore), thereby triggering `getConnection()`.
Consequently, Hikari is launched on partially initialized objects, which leads to the error logs, even though the actual data sources are correctly configured.

Could the reason be an A12-configuration property, what we should set? Didn’t found something about in rest_monitor_configuration_properties_rest_api.

The errors seem not to have impact to our application. Everything runs ok. But the ERROR loggs are very unwanted in production. They didn’t occured in A12 Version 2025.06-ext2 and before.

Another thing I noticed in that context is a warning in browser console when a buttonEvent in an overview is triggert:

Best Regards, Gunther

Hi,
About monitored-properties api, it just collect some configuration properties with original and latest value. It can not cause it create more HikariPool-3 and HikariPool-4.

To use monitor-properties, please check this prop: mgmtp.a12.uaa.authentication.unsecured.urls. It must include /api/monitored-properties value.
About error
HikariPool-3 and HikariPool-4 arise because the A12 monitoring component—via reflection—erroneously accesses the existing data sources (Pool-3 from Pool-1/dataservices; Pool-4 from Pool-2/contentstore), thereby triggering getConnection(). I can not guess where problem come from, can you give some related configuration or profile, which you have been used.

thanks, at least the ovm warning seems to be fixed.

Which specific config properties could be of use? We have lots of them ..

hi,

Which specific config properties could be of use? → which feature do you use?

For monitored-properties, you just add /api/monitored-properties into this config mgmtp.a12.uaa.authentication.unsecured.urls.

We just use a standard postgres db 15 with a standard A12 Dataservices App according project template 2025.06

We created the app with ext2 and updated to ext4.

Hi, thanks for the information. Based on your previous comments, it seems the warning has been resolved, correct?

As I mentioned, we don’t have any configuration that would create more than two Hikari pools. Have you integrated with other modules that might be initializing their own Hikari pools?

hi, the warning you mentioned seems to be fixed, but the topic ‘hikari pool error log’ is not resolved.

The special in our DS-ServerApp is, that we do not use ‘attachments’ and ‘content’ (store), but it is configured in application.yml (copied from project template)

If I remove every property that is obviously related to ‘content’ or ‘attachment’ from application.yml and start the DS-ServerApp , there 2 error messages less logged:

2026-06-03 08:56:33.309 [        ]  INFO [b-v2,,] 17420 --- [  restartedMain] org.reflections.Reflections              : Reflections took 48 ms to scan 13 urls, producing 346 keys and 1326 values

2026-06-03 08:56:33.504 [        ] ERROR [b-v2,,] 17420 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-2 - dataSource or dataSourceClassName or jdbcUrl is required.

2026-06-03 08:56:33.504 [        ] ERROR [b-v2,,] 17420 --- [  restartedMain] com.zaxxer.hikari.HikariConfig           : HikariPool-2 - dataSource or dataSourceClassName or jdbcUrl is required.

2026-06-03 08:56:33.629 [        ]  INFO [b-v2,,] 17420 --- [  restartedMain] .u.c.r.c.UAARestClientPropertiesResolver : Resolve properties for: LOCAL

But startup failes with:

***************************
APPLICATION FAILED TO START
***************************

Parameter 0 of constructor in com.mgmtp.a12.dataservices.internal.service.importer.AttachmentImporter required a bean of type 'com.mgmtp.a12.dataservices.attachment.internal.DefaultAttachmentService' that could not be found.


Action:

Consider defining a bean of type 'com.mgmtp.a12.dataservices.attachment.internal.DefaultAttachmentService' in your configuration.

I tried changing some a12-properties like:

So is here a way, to completely disable ‘attachments’ and ‘content’ (store) ?

regards

hi,
To completely disable ‘attachments’ and content store
please add this config: mgmtp.a12.dataservices.attachments.enabled=false

that’s the first entry in the config above.. :wink:

Hi,
I finally found the root cause. The error is coming from AttachmentImporter.class in dataservices-data-seed. This module is used only for the dev environment and requires the attachment feature to be enabled. As an initial workaround, could you remove this module?

ok, I removed all in configs, what looks like seed-data.

Is there flag, to disable module?

Still get:

2026-06-03 16:44:24.218 [        ] ERROR [b-v2,,] 32264 --- [  restartedMain] o.s.b.d.LoggingFailureAnalysisReporter   : 

***************************
APPLICATION FAILED TO START
***************************

Description:

Parameter 0 of constructor in com.mgmtp.a12.dataservices.internal.service.importer.AttachmentImporter required a bean of type 'com.mgmtp.a12.dataservices.attachment.internal.DefaultAttachmentService' that could not be found.

it seem, disabling attachements was not successful..

hi,
To remove usage of seed-data, you must remove it from build.gradle and remove something like:

implementation(a12Libs.dataservices.data.seed) or
dataservices-data-seed.

Then you can disabled attachments.

this is, what I’ve done (removed maven seed-dependency).

The error above appears because of missing DefaultAttachmentService .. so ist seems, disable of attachements not completely worked with

gmtp:
a12:
dataservices:
attachments:
enabled: false

hi,
Disable of attachements works by causing error miss bean.
Can you show me logs about error? Which bean continue requiring DefaultAttachmentService?

can’t you see them? It’s above .. AttachmentImporter :wink:

AttachmentImporter is inside data-seed, but since you already removed the data-seed dependency, could you please check your other dependencies? The problem might be a nested dependency pulling it back in

Hi,

in 2025.06-ext4 there is a new feature Monitoring: GetA12

The MonitorConfigurationControllerImpl controller uses a bean MonitorPropertiesData. This bean creates a default instance of HikariDataSource without HikariConfig, so the validate method in HikariConfig brings the error “dataSource or dataSourceClassName or jdbcUrl is required.”.

Kind regards, Mario