We have a document model, that uses an include to handle “attachments” (which are essentially stored inline with base64 encoding)
SME can’t handle/edit these models, but the path to the group is shown correctly.
We are importing a JSON document through A12 into the A12 document - the code has been working fine with 2022.02, but stopped working with 2022.06
The field/group looks like this in the SME:

The AttachmentToInclude.json looks like this:

The relevant part of the JSON document to be imported looks like this:
{
"AntrVerbAus" : {.....},
"Cockpit" : {
"AccountId" : "1009408638",
"Lieferticket" : "15174931291515724154361078019608",
"AllgemeineDaten" : {
"Eingang" : "2022-08-29T11:44:28",
"Ordnungskriterium" : { },
"Bundesland" : "BY",
"Status" : "neu"
},
"Gesamtfall" : {
"OriginalAnfrage" : {
"size" : 8,
"content" : "EjRWiQ==",
"mime_type" : "application/pdf",
"description" : "Test-PDF",
"internal_filename" : "file.pdf",
"original_filename" : "file.pdf"
}
}
}
}
However, DS refuses to store the document with the following error message:
com.mgmtp.a12.dataservices.utils.internal.DocumentModelException:
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/size[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/content[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/mime_type[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/description[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/internal_filename[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
For the entity instance '/Cockpit[1]/Gesamtfall[1]/OriginalAnfrage[1]/original_filename[1]', the corresponding entity was not found in the corresponding document model. [ERROR,L0,s0,e0],
This happens when sending the JSON to the DS REST endpoint using ADD_DOCUMENT_OPERATION
Is it possible, that this is caused by some change in the handling of includes in 2022.06?